Поиск по каталогам и архивам программ   
 Пример: KaZaA • English
• Новые
• ТОП
        Читаем
Софт-блог!
Поиск:   
     

На главную > Программы > Бизнес > 1С Предприятие > версия 7.7 > Оперативный учет > представление даты прописью

  Их ищут:
Aditor 3.10
Компактный, но мощный текстовый редактор, ориентированный на…

Ник без раздумий 1.1
Программа для генерирования ников.

Игромания мини 5.0
Электронный журнал про игры.

KSGL 1.0
Графическая библиотека для Turbo C++ под DOS.

Солист 1.0
Профессиональная помощь для музыкантов.

SeaFight PRO 2.0
Морской бой 15х15 с продвинутыми правилами.

Mad Checkers 3.12
Набор различных вариантов игры в шашки.

BlackHole 1.20
Шуточная программа, засасывает мышку в свои объятия.

Tower Constructor 1.0
Почувстввуй себя строителем.

Регистратор ПБОЮЛ 3.0
Подготовка заявлений для регистрации предпринимателей.

  Софт-Календарь:
21 января 1888 г. Генри Баббидж, сын Чарльза Бэббиджа, на сконструированной им по эскизам отца части его аналитической машины вычислил большое количество цифр числа пи, чтобы доказать состоятельность этого проекта.

21 января 1953 г. в Сиэттле (шт. Вашингтон) родился Пол Аллен (Paul G. Allen) - один из основателей (вторым был Билл Гейтс) корпорации Microsoft (Microcomputer Software) - американской корпорации, специализирующейся на разработке ПО для ПК.
  Новые:
Best Promotion Keyword
Утилита, эффективно составляющая ключевые слова для сайта…

Midi2Wav Recorder
Программа для автоматического преобразования аудио файлов из…

WorldTime Clock
Часы для Рабочего стола, показывающие локальное время и дату…

Guitar Power
Интерактивная обучающая система игре на гитаре. Программа…

chm2web Pro
Программа для конвертации текстовой документации в формате…

CryptoCrat
Программа для шифрования файлов. Она запаковывает выбранные…

CDex
Программа для копирования Audio CD дисков на жесткий диск…

HydraIRC
IRC-клиент с привлекательным и удобным интерфейсом…

Speedmail
Программа для быстрой отсылки электронных писем с…

Ofilter Player
Простой и удобный в работе проигрыватель мультимедийных…
  Топ-10:
3D Object Converter
Конвертер/просмотрщик большинства 3D форматов файлов с…

COPYR.DMA build 013
При восстановлении информации часто приходиться копировать…

Opera 3.0
Одна из первых версий браузера, ставшего популярным из-за…

BlueSoleil 6.4.299.0
Драйверы и программное обеспечение для управления Bluetooth…

Dream Render 2.20
Программа анимирования обоев рабочего стола Windows, которая…

EZDB
Менеджер базы данных. С возможностью создания связей между…

Movavi Видео Редактор
Кроме того, что редактирование видео само по себе очень…

zMoth 1.2.0 ML Rus
Программа для поиска и скачивания видео "для взрослых" на…

Asus Update 1.0
Программа обновления BIOS из среды Windows.

Туториалы Iczelion 1.0
Известное пособие по программированию под Win32.
   
На главную
Новости
Программы
Книги
Статьи
Новые
Топ-10
Весь софт
Мультимедиа
Утилиты
Интернет
Программирование
Игры
Десктоп
Бизнес
Драйверы
1С Предприятие
Бухгалтерия
Торговля
Складской учёт
Финансы
Документы, кадры
Органайзеры
Словари, переводчики
версия 6
версия 7.0
версия 7.5
версия 7.7
версия 8.0
Внешние компоненты
Конфигурация
Бухгалтерия
Оперативный учет
Расчет

представление даты прописью    


Обновлено 25 ноября 2005 г. 00:12:06
Рейтинг  Снижается  16 ( -2 -12.5% )
ОСWindows 95,98,ME,NT,2000,XP
Emailseregahunt@mail.ru
Авторhunter
Программы автора:
  • WinDriver Ghost - Программа для обнаружения, архивации и последующего восстановления всех драйверов, установленных в системе. Средствами программы можно создать исполняемый файл для автоматической инсталляции всех нужных драйверов.
  • "Редактор каледарей" (Обработка Календарь.ert) - Обработка "Календари"(редактор календарей для "1С:Зарплата и Кадры" - версия 1.1) Автор: Власов Сергей (seregahunt@yandex.ru), 2002г. Предоставляет возможность…
Найти все программы автора

Описание:
//*****************************************************************************
// ПрописьДата()
//
// Параметры:
// Д - дата в формате ДД.MM.ГГГГ
// Возвращаемое значение:
// дата прописью
// Описание:
//
Функция глПрописьДата(Д) Экспорт
стрРез = "";

спсМес = СоздатьОбъект("СписокЗначений");
спсМес.ДобавитьЗначение("января");
спсМес.ДобавитьЗначение("февраля");
спсМес.ДобавитьЗначение("марта");
спсМес.ДобавитьЗначение("апреля");
спсМес.ДобавитьЗначение("мая");
спсМес.ДобавитьЗначение("июня");
спсМес.ДобавитьЗначение("июля");
спсМес.ДобавитьЗначение("августа");
спсМес.ДобавитьЗначение("сентября");
спсМес.ДобавитьЗначение("октября");
спсМес.ДобавитьЗначение("ноября");
спсМес.ДобавитьЗначение("декабря");

спсЧисл = СоздатьОбъект("СписокЗначений");
спсЧисл.ДобавитьЗначение("первое","первого");
спсЧисл.ДобавитьЗначение("второе","второго");
спсЧисл.ДобавитьЗначение("третье","третьего");
спсЧисл.ДобавитьЗначение("четвертое","четвертого");
спсЧисл.ДобавитьЗначение("пятое","пятого");
спсЧисл.ДобавитьЗначение("шестое","шестого");
спсЧисл.ДобавитьЗначение("седьмое","седьмого");
спсЧисл.ДобавитьЗначение("восьмое","восьмого");
спсЧисл.ДобавитьЗначение("девятое","девятого");

//числительные им.падеж
спсЧислИм = СоздатьОбъект("СписокЗначений");
спсЧислИм.ДобавитьЗначение("тысяча","тысячного");
спсЧислИм.ДобавитьЗначение("две тысячи","двухтысячного");
спсЧислИм.ДобавитьЗначение("три тысячи","трехтысячного");
спсЧислИм.ДобавитьЗначение("четыре тысячи","четырехтысячного");
спсЧислИм.ДобавитьЗначение("пять","пятитысячного");
спсЧислИм.ДобавитьЗначение("шесть","шеститысячного");
спсЧислИм.ДобавитьЗначение("семь","семитысячного");
спсЧислИм.ДобавитьЗначение("восемь","восьмитысячного");
спсЧислИм.ДобавитьЗначение("девять","девятитысячного");

спсСотни = СоздатьОбъект("СписокЗначений");
спсСотни.ДобавитьЗначение("сто");
спсСотни.ДобавитьЗначение("двести");
спсСотни.ДобавитьЗначение("триста");
спсСотни.ДобавитьЗначение("четыреста");
спсСотни.ДобавитьЗначение("пятьсот");
спсСотни.ДобавитьЗначение("шестьсот");
спсСотни.ДобавитьЗначение("семьсот");
спсСотни.ДобавитьЗначение("восемьсот");
спсСотни.ДобавитьЗначение("девятьсот");

//десятки им.падеж
спсДесИм = СоздатьОбъект("СписокЗначений");
спсДесИм.ДобавитьЗначение("","десятого");
спсДесИм.ДобавитьЗначение("двадцать","двадцатого");
спсДесИм.ДобавитьЗначение("тридцать","тридцатого");
спсДесИм.ДобавитьЗначение("сорок","сорокового");
спсДесИм.ДобавитьЗначение("пятьдесят","пятидесятого");
спсДесИм.ДобавитьЗначение("шестьдесят","шестидесятого");
спсДесИм.ДобавитьЗначение("семьдесят","семидесятого");
спсДесИм.ДобавитьЗначение("восемьдесят","восьмидесятого");
спсДесИм.ДобавитьЗначение("девяносто","девяностого");

//субдесятки род.падеж
спсСубДесРод = СоздатьОбъект("СписокЗначений");
спсСубДесРод.ДобавитьЗначение("одиннадцатого");
спсСубДесРод.ДобавитьЗначение("двенадцатого");
спсСубДесРод.ДобавитьЗначение("тринадцатого");
спсСубДесРод.ДобавитьЗначение("четырнадцатого");
спсСубДесРод.ДобавитьЗначение("пятнадцатого");
спсСубДесРод.ДобавитьЗначение("шестнадцатого");
спсСубДесРод.ДобавитьЗначение("семнадцатого");
спсСубДесРод.ДобавитьЗначение("восемнадцатого");
спсСубДесРод.ДобавитьЗначение("девятнадцатого");

спсДес = СоздатьОбъект("СписокЗначений");
спсДес.ДобавитьЗначение("десятое");
спсДес.ДобавитьЗначение("двадцатое","двадцать");
спсДес.ДобавитьЗначение("тридцатое","тридцать");
спсДес.ДобавитьЗначение("сороковое","тридцать");
спсДес.ДобавитьЗначение("пятидесятое","тридцать");
спсДес.ДобавитьЗначение("шестидесятое","тридцать");
спсДес.ДобавитьЗначение("семидесятое","тридцать");

спсСубДес = СоздатьОбъект("СписокЗначений");
спсСубДес.ДобавитьЗначение("одиннадцатое");
спсСубДес.ДобавитьЗначение("двенадцатое");
спсСубДес.ДобавитьЗначение("тринадцатое");
спсСубДес.ДобавитьЗначение("четырнадцатое");
спсСубДес.ДобавитьЗначение("пятнадцатое");
спсСубДес.ДобавитьЗначение("шестнадцатое");
спсСубДес.ДобавитьЗначение("семнадцатое");
спсСубДес.ДобавитьЗначение("восемнадцатое");
спсСубДес.ДобавитьЗначение("девятнадцатое");

спсДаты = СтрЗаменить(СокрЛП(Д),".",РазделительСтрок);
//разбираем день
стрДень = СокрЛП(Число(СтрПолучитьСтроку(спсДаты,1)));
Если СтрДлина(стрДень)=1 Тогда
стрДень = спсЧисл.ПолучитьЗначение(Число(стрДень));
Иначе
десДень = Число(Лев(стрДень,1));
едДень = Число(Прав(стрДень,1));

Если едДень=0 Тогда
стрДень = спсДес.ПолучитьЗначение(десДень);
Иначе
Если десДень>1 Тогда
т = ""; спсДес.ПолучитьЗначение(десДень,т);
стрДень = т+" "+спсЧисл.ПолучитьЗначение(едДень);
Иначе
стрДень = спсСубДес.ПолучитьЗначение(едДень);
КонецЕсли;
КонецЕсли;
КонецЕсли;
//разбираем месяц
стрМес = спсМес.ПолучитьЗначение(Число(СтрПолучитьСтроку(спсДаты,2)));

//разбираем год
стрГод = СтрПолучитьСтроку(спсДаты,3);
длинаГода = СтрДлина(стрГод);
Если длинаГода=4 Тогда
тыс = Сред(стрГод,1,1); сот = Сред(стрГод,2,1); дес = Сред(стрГод,3,1); ед = Сред(стрГод,4,1);
_т = спсЧислИм.ПолучитьЗначение(Число(тыс));
Если (Число(сот)=0) и (Число(дес)=0) и (Число(ед)=0) Тогда
миллениум = ""; спсЧислИм.ПолучитьЗначение(Число(тыс),миллениум);
стрГод = миллениум;
Иначе
с = ""; дс = ""; е = "";
Если Число(сот)0 Тогда
с = спсСотни.ПолучитьЗначение(Число(сот));
КонецЕсли;
Если Число(дес)0 Тогда
Если Число(ед)=0 Тогда
_дг = ""; спсДесИм.ПолучитьЗначение(Число(дес),_дг);
дс = _дг;
Иначе
Если Число(дес)>1 Тогда
дс = спсДесИм.ПолучитьЗначение(Число(дес));
Иначе
дс = спсСубДесРод.ПолучитьЗначение(Число(ед));
КонецЕсли;

КонецЕсли;
КонецЕсли;
Если (Число(дес)>1) или (Число(дес)=0) Тогда
Если Число(ед)0 Тогда
//е = "";
спсЧисл.ПолучитьЗначение(Число(ед),е);
КонецЕсли;
КонецЕсли;
стрГод = _т+?(ПустоеЗначение(с)=0," ","")+с+?(ПУстоеЗначение(дс)=0," ","")+дс+" "+е;
КонецЕсли;
Иначе

КонецЕсли;
стрГод = стрГод+" года";
стрРез = стрДень+" "+стрМес+" "+стрГод;
//Сообщить(стрДень+" "+стрМес+" "+стрГод);
Возврат стрРез;
КонецФункции //ПрописьДата*/
Загрузить  Загрузить представление даты прописью на 1c.proclub.ru
Найти последнюю версиюНайти последнюю версию представление даты прописью

Похожие программы:
    Найти все программы похожие на представление даты прописью

    Похожие новости:
    • Archos 604 – практически официальное представление - Вслед за свои братом Archos 404 представлен новый современный портативный мультимедиа плеер Archos 604. Сегодня мы имеем честь представить вам полные спецификации этого…
    • Предсказана дата смерти iPhone - Ресурс PC Mag создал специальную страничку, на которой владельцы iPhone смогут узнать, когда «умрет» их телефон. Вы просто вводите дату покупки iPhone и получаете точную…
    Найти все новости похожие на представление даты прописью

    Похожие статьи:
    Найти все статьи похожие на представление даты прописью


    На главную > Программы > Бизнес > 1С Предприятие > версия 7.7 > Оперативный учет > представление даты прописью

    скачай также:
    EMS SQL Manager 2005 Lite for…
    VLC media player
    RVDT 0.2
    download also english software:
    VersaSRS - Help Desk - Service Desk… 4.1.0
    UniversalIndentGUI 1.2.0
    Video Stock Box 2.00
    скачай также:
    Интеллект-тренажер №1
    NitroAmplifire! 0.74a
    iuVCR 4.2.0.258

    Copyright © 2001—2018 SoftSearch
    Идея:
    Дизайн: Дамир Салахов
    Реклама на сайте
    Контакты: