Поиск по каталогам и архивам программ   
 Пример: KaZaA • English
• Новые
• ТОП
        Читаем
Софт-блог!
Поиск:   
     

На главную > Программы > Бизнес > 1С Предприятие > версия 7.7 > Оперативный учет > представление даты прописью

  Их ищут:
Snowf 1.7.4
ГРАФИЧЕСКИЙ РЕДАКТОР Для рисования симметричных рисунков…

ID-Blaster Plus 2.0
Утилита для оперативной смены ID-номеров системы и…

IrLex 0.17-RC
Очень качественный консольный telnet-клиент. Если не…

Kremlin Deluxe 1.0
Программа поможет высчитать у.е. для известной Кремлевской…

еКаталог 1.1
Ведение и тиражирование электронных иллюстрированных…

Интернет-магазин 7.1
Создание магазинов в Интернете, либо для внутреннего…

Solitaire Online 1.0
Сетевая игра в пасьянс.

Лабиринт 0.3
Программа построения лабиринтов.

Dream Day Wedding 1.0
Совершите романтическое свадебное путешествие.

Hard Life of Virus 1.0
Почувствуйте себя в шкуре компьютерного вируса.

  Софт-Календарь:
27 мая 1959 г. были сняты с эксплуатации компьютеры "Вихрь-1", которые работали в системе контроля за воздушными полетами и раннего предупреждения в США, но "Вихрь-2" работал в этой системе до 1980 г.
  Новые:
MiniPay-SL
Бухгалтерская программа для создания, печати и учета…

RapidDriver
Инструмент для разработки драйверов устройств и отладки…

Karens Time Sync
Программа для синхронизации времени через Интернет…

Red Button
Утилита для быстрого доступа к различным системным элементам…

LockMyText
Инструмент защиты текста, используемый для надежной отправки…

RecoMP3
Программа для уменьшения размеров MP3 файлов. RecoMP3…

LMA manager 2007
Станьте управляющим клубом одной из 5 ведущих европейских…

Duplicate File Detector
Мощный инструмент для поиска дублирующихся файлов на дисках…

GigaTribe
Программа для организации частной пиринговой сети (P2P). Для…

xsubst
Функциональный аналог консольной утилиты subst, позволяющий…
  Топ-10:
Сборник иконок 17.0
Всем, кто когда-то искал себе замену иконки, скажем на «Мой…

Русификация Winamp 2.79
Русификация популярного плеера Winamp версии 2.79

Graph2Digit 0.62
Программа служит для оцифровки графиков с рисунков…

VirtGuard 2.02.14
Цифровая система видеонаблюдения. С помощью цифровой или…

M3u 2 RF 1.0
M3u 2 RF - Из плейлиста (файл *.m3u) копирует в папку с…

Sky ScreenSaver 1.1
Заставка, показывающее небо над любой точкой Земли в…

Vegas 7.0b
Vegas - Мощная система нелинейного видео и аудио монтажа…

Эмулятор Siemens M55
Эмулятор телефона Siemens M55

Galloper CRM 1.0
Бесплатная CRM-программа для отделов продаж.

Штрих-кодер 1.5
Построение изображений штриховых кодов.
   
На главную
Новости
Программы
Книги
Статьи
Новые
Топ-10
Весь софт
Мультимедиа
Утилиты
Интернет
Программирование
Игры
Десктоп
Бизнес
Драйверы
1С Предприятие
Бухгалтерия
Торговля
Складской учёт
Финансы
Документы, кадры
Органайзеры
Словари, переводчики
версия 6
версия 7.0
версия 7.5
версия 7.7
версия 8.0
Внешние компоненты
Конфигурация
Бухгалтерия
Оперативный учет
Расчет

представление даты прописью    


Обновлено 25 ноября 2005 г. 00:12:06
Рейтинг  Снижается  16 ( -2 -12.5% )
ОСWindows 95,98,ME,NT,2000,XP
Emailseregahunt@mail.ru
Авторhunter
Программы автора:
  • WinDriver Ghost - Программа для обнаружения, архивации и последующего восстановления всех драйверов, установленных в системе. Средствами программы можно создать исполняемый файл для автоматической инсталляции всех нужных драйверов.
  • Отчет "Расчетные листки" - модифицрованный отчет "Расчетные листки" из 1С:Зарплата и Кадры.Позволяет формировать расч.листки по сотрам за период, как сводные, так и помесячно.
Найти все программы автора

Описание:
//*****************************************************************************
// ПрописьДата()
//
// Параметры:
// Д - дата в формате ДД.MM.ГГГГ
// Возвращаемое значение:
// дата прописью
// Описание:
//
Функция глПрописьДата(Д) Экспорт
стрРез = "";

спсМес = СоздатьОбъект("СписокЗначений");
спсМес.ДобавитьЗначение("января");
спсМес.ДобавитьЗначение("февраля");
спсМес.ДобавитьЗначение("марта");
спсМес.ДобавитьЗначение("апреля");
спсМес.ДобавитьЗначение("мая");
спсМес.ДобавитьЗначение("июня");
спсМес.ДобавитьЗначение("июля");
спсМес.ДобавитьЗначение("августа");
спсМес.ДобавитьЗначение("сентября");
спсМес.ДобавитьЗначение("октября");
спсМес.ДобавитьЗначение("ноября");
спсМес.ДобавитьЗначение("декабря");

спсЧисл = СоздатьОбъект("СписокЗначений");
спсЧисл.ДобавитьЗначение("первое","первого");
спсЧисл.ДобавитьЗначение("второе","второго");
спсЧисл.ДобавитьЗначение("третье","третьего");
спсЧисл.ДобавитьЗначение("четвертое","четвертого");
спсЧисл.ДобавитьЗначение("пятое","пятого");
спсЧисл.ДобавитьЗначение("шестое","шестого");
спсЧисл.ДобавитьЗначение("седьмое","седьмого");
спсЧисл.ДобавитьЗначение("восьмое","восьмого");
спсЧисл.ДобавитьЗначение("девятое","девятого");

//числительные им.падеж
спсЧислИм = СоздатьОбъект("СписокЗначений");
спсЧислИм.ДобавитьЗначение("тысяча","тысячного");
спсЧислИм.ДобавитьЗначение("две тысячи","двухтысячного");
спсЧислИм.ДобавитьЗначение("три тысячи","трехтысячного");
спсЧислИм.ДобавитьЗначение("четыре тысячи","четырехтысячного");
спсЧислИм.ДобавитьЗначение("пять","пятитысячного");
спсЧислИм.ДобавитьЗначение("шесть","шеститысячного");
спсЧислИм.ДобавитьЗначение("семь","семитысячного");
спсЧислИм.ДобавитьЗначение("восемь","восьмитысячного");
спсЧислИм.ДобавитьЗначение("девять","девятитысячного");

спсСотни = СоздатьОбъект("СписокЗначений");
спсСотни.ДобавитьЗначение("сто");
спсСотни.ДобавитьЗначение("двести");
спсСотни.ДобавитьЗначение("триста");
спсСотни.ДобавитьЗначение("четыреста");
спсСотни.ДобавитьЗначение("пятьсот");
спсСотни.ДобавитьЗначение("шестьсот");
спсСотни.ДобавитьЗначение("семьсот");
спсСотни.ДобавитьЗначение("восемьсот");
спсСотни.ДобавитьЗначение("девятьсот");

//десятки им.падеж
спсДесИм = СоздатьОбъект("СписокЗначений");
спсДесИм.ДобавитьЗначение("","десятого");
спсДесИм.ДобавитьЗначение("двадцать","двадцатого");
спсДесИм.ДобавитьЗначение("тридцать","тридцатого");
спсДесИм.ДобавитьЗначение("сорок","сорокового");
спсДесИм.ДобавитьЗначение("пятьдесят","пятидесятого");
спсДесИм.ДобавитьЗначение("шестьдесят","шестидесятого");
спсДесИм.ДобавитьЗначение("семьдесят","семидесятого");
спсДесИм.ДобавитьЗначение("восемьдесят","восьмидесятого");
спсДесИм.ДобавитьЗначение("девяносто","девяностого");

//субдесятки род.падеж
спсСубДесРод = СоздатьОбъект("СписокЗначений");
спсСубДесРод.ДобавитьЗначение("одиннадцатого");
спсСубДесРод.ДобавитьЗначение("двенадцатого");
спсСубДесРод.ДобавитьЗначение("тринадцатого");
спсСубДесРод.ДобавитьЗначение("четырнадцатого");
спсСубДесРод.ДобавитьЗначение("пятнадцатого");
спсСубДесРод.ДобавитьЗначение("шестнадцатого");
спсСубДесРод.ДобавитьЗначение("семнадцатого");
спсСубДесРод.ДобавитьЗначение("восемнадцатого");
спсСубДесРод.ДобавитьЗначение("девятнадцатого");

спсДес = СоздатьОбъект("СписокЗначений");
спсДес.ДобавитьЗначение("десятое");
спсДес.ДобавитьЗначение("двадцатое","двадцать");
спсДес.ДобавитьЗначение("тридцатое","тридцать");
спсДес.ДобавитьЗначение("сороковое","тридцать");
спсДес.ДобавитьЗначение("пятидесятое","тридцать");
спсДес.ДобавитьЗначение("шестидесятое","тридцать");
спсДес.ДобавитьЗначение("семидесятое","тридцать");

спсСубДес = СоздатьОбъект("СписокЗначений");
спсСубДес.ДобавитьЗначение("одиннадцатое");
спсСубДес.ДобавитьЗначение("двенадцатое");
спсСубДес.ДобавитьЗначение("тринадцатое");
спсСубДес.ДобавитьЗначение("четырнадцатое");
спсСубДес.ДобавитьЗначение("пятнадцатое");
спсСубДес.ДобавитьЗначение("шестнадцатое");
спсСубДес.ДобавитьЗначение("семнадцатое");
спсСубДес.ДобавитьЗначение("восемнадцатое");
спсСубДес.ДобавитьЗначение("девятнадцатое");

спсДаты = СтрЗаменить(СокрЛП(Д),".",РазделительСтрок);
//разбираем день
стрДень = СокрЛП(Число(СтрПолучитьСтроку(спсДаты,1)));
Если СтрДлина(стрДень)=1 Тогда
стрДень = спсЧисл.ПолучитьЗначение(Число(стрДень));
Иначе
десДень = Число(Лев(стрДень,1));
едДень = Число(Прав(стрДень,1));

Если едДень=0 Тогда
стрДень = спсДес.ПолучитьЗначение(десДень);
Иначе
Если десДень>1 Тогда
т = ""; спсДес.ПолучитьЗначение(десДень,т);
стрДень = т+" "+спсЧисл.ПолучитьЗначение(едДень);
Иначе
стрДень = спсСубДес.ПолучитьЗначение(едДень);
КонецЕсли;
КонецЕсли;
КонецЕсли;
//разбираем месяц
стрМес = спсМес.ПолучитьЗначение(Число(СтрПолучитьСтроку(спсДаты,2)));

//разбираем год
стрГод = СтрПолучитьСтроку(спсДаты,3);
длинаГода = СтрДлина(стрГод);
Если длинаГода=4 Тогда
тыс = Сред(стрГод,1,1); сот = Сред(стрГод,2,1); дес = Сред(стрГод,3,1); ед = Сред(стрГод,4,1);
_т = спсЧислИм.ПолучитьЗначение(Число(тыс));
Если (Число(сот)=0) и (Число(дес)=0) и (Число(ед)=0) Тогда
миллениум = ""; спсЧислИм.ПолучитьЗначение(Число(тыс),миллениум);
стрГод = миллениум;
Иначе
с = ""; дс = ""; е = "";
Если Число(сот)0 Тогда
с = спсСотни.ПолучитьЗначение(Число(сот));
КонецЕсли;
Если Число(дес)0 Тогда
Если Число(ед)=0 Тогда
_дг = ""; спсДесИм.ПолучитьЗначение(Число(дес),_дг);
дс = _дг;
Иначе
Если Число(дес)>1 Тогда
дс = спсДесИм.ПолучитьЗначение(Число(дес));
Иначе
дс = спсСубДесРод.ПолучитьЗначение(Число(ед));
КонецЕсли;

КонецЕсли;
КонецЕсли;
Если (Число(дес)>1) или (Число(дес)=0) Тогда
Если Число(ед)0 Тогда
//е = "";
спсЧисл.ПолучитьЗначение(Число(ед),е);
КонецЕсли;
КонецЕсли;
стрГод = _т+?(ПустоеЗначение(с)=0," ","")+с+?(ПУстоеЗначение(дс)=0," ","")+дс+" "+е;
КонецЕсли;
Иначе

КонецЕсли;
стрГод = стрГод+" года";
стрРез = стрДень+" "+стрМес+" "+стрГод;
//Сообщить(стрДень+" "+стрМес+" "+стрГод);
Возврат стрРез;
КонецФункции //ПрописьДата*/
Загрузить  Загрузить представление даты прописью на 1c.proclub.ru
Найти последнюю версиюНайти последнюю версию представление даты прописью

Похожие программы:
    Найти все программы похожие на представление даты прописью

    Похожие новости:
    • Archos 604 – практически официальное представление - Вслед за свои братом Archos 404 представлен новый современный портативный мультимедиа плеер Archos 604. Сегодня мы имеем честь представить вам полные спецификации этого…
    • Предсказана дата смерти iPhone - Ресурс PC Mag создал специальную страничку, на которой владельцы iPhone смогут узнать, когда «умрет» их телефон. Вы просто вводите дату покупки iPhone и получаете точную…
    Найти все новости похожие на представление даты прописью

    Похожие статьи:
    Найти все статьи похожие на представление даты прописью


    На главную > Программы > Бизнес > 1С Предприятие > версия 7.7 > Оперативный учет > представление даты прописью

    скачай также:
    Wise Popup
    Simple Gmail Message Maker 1.1
    Simple Link Finder 1.0
    download also english software:
    SecretsSaver Personal Pro 2.0
    HTML Web Design Software 2.0
    Concentration 2.0.5
    скачай также:
    Рамки для фотографий: Цветочная…
    Техношар 2.11
    Путеводство 1.1

    Copyright © 2001—2016 SoftSearch
    Идея:
    Дизайн: Дамир Салахов
    Реклама на сайте
    Контакты: