Поиск по каталогам и архивам программ   
 Пример: • English
• Новые
• ТОП
        Читаем
Софт-блог!
Поиск:   
     

На главную > Программы > Бизнес > 1С Предприятие > версия 7.7 > представление даты прописью

  Их ищут:
Мой Домовой 2.2
Многие ли могут точно ответить на вопрос "куда уходят…

Афоризмы 2.0
Афоризмы - в этой программе содержутся более 2000 тысяч…

Транслятор Снов 2.0.0.3
Расшифровка снов, написанного в произвольной форме.

Журнал МегаРжач №3 3.0
А вот и очередной уже третий номер развлекательно…

Поваренок 8
Кулинарный журнал.

SeaFight PRO 2.0
Морской бой 15х15 с продвинутыми правилами.

Zenitka-Мухобойка 1.0
Игра-стрелялка.

Digger XP 1.0
Новая вресия классического Diggera.

Amazing Tetris 1.50
Тетрис с фигурками из треугольников и квадратиков.

Мини-Смета 1.1
Программа составления смет для ремонта и строительства.

  Софт-Календарь:
В 1936 г. в Будапеште родился Эндрю Гроув (Grove) (настоящее имя Андраш Гроф) - американский ученый и предприниматель венгерского происхождения, председатель и главный исполнительный директор корпорации Intel - мирового лидера в области микропроцессоров.
  Новые:
ezProxy
Прокси-сервер, позволяющий делать доступ для всей сети в…

Organizer MP3
Программа для создания музыкальных МР3-коллекций, готовых…

TablEdit
Нотный редактор, позволяющий писать музыку прямо на…

Virtual Null Modem
Программа эмулирует работу двух последовательных портов…

Cheez
Удобный инструмент просмотра и каталогизации изображений…

ПАМЯТьНИК
Небольшая программа, которая может показывать информацию о…

Web Pictures Downloader
Программа для скачивания картинок различных форматов и…

RSS Feeder
RSS-агрегатор, который загружает из Интернета выбранные вами…

Perl Module Manager
Утилита для инсталляции, деинсталляции и управления…

Text2Web Pro
Программа для конвертации текстовых данных в формат HTML…
  Топ-10:
БК Марафон 1.0.2.6
Даная программа разработана для автоматических ставок на…

Журнал трейдера 1.1
Журнал трейдера - программа предназначена для учета биржевых…

Renex III 3.0.002
Renex III - прекрасно оформленная логическая игра "5 в ряд…

CCleaner 2.24.1010
CCleaner - это утилита для оптимизации системы, а также…

ShutDown v1.17
ShutDown - программа полностью выключает компьютер в…

Access2MySQL 1.1
Утилита, конвертирующая базы данных MS Access в MySQL и…

Spiral 1.1
Специализированный графический редактор для рисования…

Findbus 1.0
Поиск на карте схем движения маршрутных такси г. Бишкек

Coloplop v1.5
Игра головоломка-приключение симпатичного съедобного…

Lines v1.0
Написано специально под PC/XT CGA вариант "Lines". Может не…
   
На главную
Новости
Программы
Книги
Статьи
Новые
Топ-10
Весь софт
Мультимедиа
Утилиты
Интернет
Программирование
Игры
Десктоп
Бизнес
Драйверы
1С Предприятие
Бухгалтерия
Торговля
Складской учёт
Финансы
Документы, кадры
Органайзеры
Словари, переводчики
версия 6
версия 7.0
версия 7.5
версия 7.7
версия 8.0
Внешние компоненты
Конфигурация
Бухгалтерия
Оперативный учет
Расчет

представление даты прописью    


Обновлено 25 ноября 2005 г. 00:11:55
Рейтинг 0
ОСWindows 95,98,ME,NT,2000,XP
Emailseregahunt@mail.ru
Авторhunter
Программы автора:
  • WinDriver Ghost - Программа для обнаружения, архивации и последующего восстановления всех драйверов, установленных в системе. Средствами программы можно создать исполняемый файл для автоматической инсталляции всех нужных драйверов.
  • Отчет "Расчетные листки" - модифицрованный отчет "Расчетные листки" из 1С:Зарплата и Кадры.Позволяет формировать расч.листки по сотрам за период, как сводные, так и помесячно.
Найти все программы автора

Описание:
//*****************************************************************************
// ПрописьДата()
//
// Параметры:
// Д - дата в формате ДД.MM.ГГГГ
// Возвращаемое значение:
// дата прописью
// Описание:
//
Функция глПрописьДата(Д) Экспорт
стрРез = "";

спсМес = СоздатьОбъект("СписокЗначений");
спсМес.ДобавитьЗначение("января");
спсМес.ДобавитьЗначение("февраля");
спсМес.ДобавитьЗначение("марта");
спсМес.ДобавитьЗначение("апреля");
спсМес.ДобавитьЗначение("мая");
спсМес.ДобавитьЗначение("июня");
спсМес.ДобавитьЗначение("июля");
спсМес.ДобавитьЗначение("августа");
спсМес.ДобавитьЗначение("сентября");
спсМес.ДобавитьЗначение("октября");
спсМес.ДобавитьЗначение("ноября");
спсМес.ДобавитьЗначение("декабря");

спсЧисл = СоздатьОбъект("СписокЗначений");
спсЧисл.ДобавитьЗначение("первое","первого");
спсЧисл.ДобавитьЗначение("второе","второго");
спсЧисл.ДобавитьЗначение("третье","третьего");
спсЧисл.ДобавитьЗначение("четвертое","четвертого");
спсЧисл.ДобавитьЗначение("пятое","пятого");
спсЧисл.ДобавитьЗначение("шестое","шестого");
спсЧисл.ДобавитьЗначение("седьмое","седьмого");
спсЧисл.ДобавитьЗначение("восьмое","восьмого");
спсЧисл.ДобавитьЗначение("девятое","девятого");

//числительные им.падеж
спсЧислИм = СоздатьОбъект("СписокЗначений");
спсЧислИм.ДобавитьЗначение("тысяча","тысячного");
спсЧислИм.ДобавитьЗначение("две тысячи","двухтысячного");
спсЧислИм.ДобавитьЗначение("три тысячи","трехтысячного");
спсЧислИм.ДобавитьЗначение("четыре тысячи","четырехтысячного");
спсЧислИм.ДобавитьЗначение("пять","пятитысячного");
спсЧислИм.ДобавитьЗначение("шесть","шеститысячного");
спсЧислИм.ДобавитьЗначение("семь","семитысячного");
спсЧислИм.ДобавитьЗначение("восемь","восьмитысячного");
спсЧислИм.ДобавитьЗначение("девять","девятитысячного");

спсСотни = СоздатьОбъект("СписокЗначений");
спсСотни.ДобавитьЗначение("сто");
спсСотни.ДобавитьЗначение("двести");
спсСотни.ДобавитьЗначение("триста");
спсСотни.ДобавитьЗначение("четыреста");
спсСотни.ДобавитьЗначение("пятьсот");
спсСотни.ДобавитьЗначение("шестьсот");
спсСотни.ДобавитьЗначение("семьсот");
спсСотни.ДобавитьЗначение("восемьсот");
спсСотни.ДобавитьЗначение("девятьсот");

//десятки им.падеж
спсДесИм = СоздатьОбъект("СписокЗначений");
спсДесИм.ДобавитьЗначение("","десятого");
спсДесИм.ДобавитьЗначение("двадцать","двадцатого");
спсДесИм.ДобавитьЗначение("тридцать","тридцатого");
спсДесИм.ДобавитьЗначение("сорок","сорокового");
спсДесИм.ДобавитьЗначение("пятьдесят","пятидесятого");
спсДесИм.ДобавитьЗначение("шестьдесят","шестидесятого");
спсДесИм.ДобавитьЗначение("семьдесят","семидесятого");
спсДесИм.ДобавитьЗначение("восемьдесят","восьмидесятого");
спсДесИм.ДобавитьЗначение("девяносто","девяностого");

//субдесятки род.падеж
спсСубДесРод = СоздатьОбъект("СписокЗначений");
спсСубДесРод.ДобавитьЗначение("одиннадцатого");
спсСубДесРод.ДобавитьЗначение("двенадцатого");
спсСубДесРод.ДобавитьЗначение("тринадцатого");
спсСубДесРод.ДобавитьЗначение("четырнадцатого");
спсСубДесРод.ДобавитьЗначение("пятнадцатого");
спсСубДесРод.ДобавитьЗначение("шестнадцатого");
спсСубДесРод.ДобавитьЗначение("семнадцатого");
спсСубДесРод.ДобавитьЗначение("восемнадцатого");
спсСубДесРод.ДобавитьЗначение("девятнадцатого");

спсДес = СоздатьОбъект("СписокЗначений");
спсДес.ДобавитьЗначение("десятое");
спсДес.ДобавитьЗначение("двадцатое","двадцать");
спсДес.ДобавитьЗначение("тридцатое","тридцать");
спсДес.ДобавитьЗначение("сороковое","тридцать");
спсДес.ДобавитьЗначение("пятидесятое","тридцать");
спсДес.ДобавитьЗначение("шестидесятое","тридцать");
спсДес.ДобавитьЗначение("семидесятое","тридцать");

спсСубДес = СоздатьОбъект("СписокЗначений");
спсСубДес.ДобавитьЗначение("одиннадцатое");
спсСубДес.ДобавитьЗначение("двенадцатое");
спсСубДес.ДобавитьЗначение("тринадцатое");
спсСубДес.ДобавитьЗначение("четырнадцатое");
спсСубДес.ДобавитьЗначение("пятнадцатое");
спсСубДес.ДобавитьЗначение("шестнадцатое");
спсСубДес.ДобавитьЗначение("семнадцатое");
спсСубДес.ДобавитьЗначение("восемнадцатое");
спсСубДес.ДобавитьЗначение("девятнадцатое");

спсДаты = СтрЗаменить(СокрЛП(Д),".",РазделительСтрок);
//разбираем день
стрДень = СокрЛП(Число(СтрПолучитьСтроку(спсДаты,1)));
Если СтрДлина(стрДень)=1 Тогда
стрДень = спсЧисл.ПолучитьЗначение(Число(стрДень));
Иначе
десДень = Число(Лев(стрДень,1));
едДень = Число(Прав(стрДень,1));

Если едДень=0 Тогда
стрДень = спсДес.ПолучитьЗначение(десДень);
Иначе
Если десДень>1 Тогда
т = ""; спсДес.ПолучитьЗначение(десДень,т);
стрДень = т+" "+спсЧисл.ПолучитьЗначение(едДень);
Иначе
стрДень = спсСубДес.ПолучитьЗначение(едДень);
КонецЕсли;
КонецЕсли;
КонецЕсли;
//разбираем месяц
стрМес = спсМес.ПолучитьЗначение(Число(СтрПолучитьСтроку(спсДаты,2)));

//разбираем год
стрГод = СтрПолучитьСтроку(спсДаты,3);
длинаГода = СтрДлина(стрГод);
Если длинаГода=4 Тогда
тыс = Сред(стрГод,1,1); сот = Сред(стрГод,2,1); дес = Сред(стрГод,3,1); ед = Сред(стрГод,4,1);
_т = спсЧислИм.ПолучитьЗначение(Число(тыс));
Если (Число(сот)=0) и (Число(дес)=0) и (Число(ед)=0) Тогда
миллениум = ""; спсЧислИм.ПолучитьЗначение(Число(тыс),миллениум);
стрГод = миллениум;
Иначе
с = ""; дс = ""; е = "";
Если Число(сот)0 Тогда
с = спсСотни.ПолучитьЗначение(Число(сот));
КонецЕсли;
Если Число(дес)0 Тогда
Если Число(ед)=0 Тогда
_дг = ""; спсДесИм.ПолучитьЗначение(Число(дес),_дг);
дс = _дг;
Иначе
Если Число(дес)>1 Тогда
дс = спсДесИм.ПолучитьЗначение(Число(дес));
Иначе
дс = спсСубДесРод.ПолучитьЗначение(Число(ед));
КонецЕсли;

КонецЕсли;
КонецЕсли;
Если (Число(дес)>1) или (Число(дес)=0) Тогда
Если Число(ед)0 Тогда
//е = "";
спсЧисл.ПолучитьЗначение(Число(ед),е);
КонецЕсли;
КонецЕсли;
стрГод = _т+?(ПустоеЗначение(с)=0," ","")+с+?(ПУстоеЗначение(дс)=0," ","")+дс+" "+е;
КонецЕсли;
Иначе

КонецЕсли;
стрГод = стрГод+" года";
стрРез = стрДень+" "+стрМес+" "+стрГод;
//Сообщить(стрДень+" "+стрМес+" "+стрГод);
Возврат стрРез;
КонецФункции //ПрописьДата*/
Загрузить  Загрузить представление даты прописью на 1c.proclub.ru
Найти последнюю версиюНайти последнюю версию представление даты прописью

Похожие программы:
    Найти все программы похожие на представление даты прописью

    Похожие новости:
    • Archos 604 – практически официальное представление - Вслед за свои братом Archos 404 представлен новый современный портативный мультимедиа плеер Archos 604. Сегодня мы имеем честь представить вам полные спецификации этого…
    • Предсказана дата смерти iPhone - Ресурс PC Mag создал специальную страничку, на которой владельцы iPhone смогут узнать, когда «умрет» их телефон. Вы просто вводите дату покупки iPhone и получаете точную…
    Найти все новости похожие на представление даты прописью

    Похожие статьи:
    Найти все статьи похожие на представление даты прописью


    На главную > Программы > Бизнес > 1С Предприятие > версия 7.7 > представление даты прописью

    скачай также:
    ActiveURLs Check&Get Free 1.14
    ScanPartner 600C » Fujitsu Twain driver
    M3099GH/GX » Fujitsu Twain driver
    download also english software:
    diskSpace Explorer Network Edition 3.0
    Free PC Memory Shield v6.0.1
    IP2Location Application 1.00
    скачай также:
    Хранитель экрана "Шоссе" 1.00
    Photo DVD Maker Professional 8.08 Rus
    VoiceMan 2.01

    Copyright © 2001—2016 SoftSearch
    Идея:
    Дизайн: Дамир Салахов
    Реклама на сайте
    Контакты: