Поиск по каталогам и архивам программ   
 Пример: клавиатурный тренажер • English
• Новые
• ТОП
        Читаем
Софт-блог!
Поиск:   
     

На главную > Программы > Бизнес > 1С Предприятие > версия 7.7 > Расчет > представление даты прописью

  Их ищут:
Пингвин 3.1
Программа "Пингвин" предназначена для контроля за входом и…

Golden Pen 1.5
Многооконный текстовый редактор. Выделение синтаксиса…

Shop-Script PREMIUM 1.1
Shop-Script PREMIUM - программное обеспечение для…

OSG WebShop 1.3.13
Интернет-магазин.

Штрих-кодер 1.5
Построение изображений штриховых кодов.

Осьминожек 1.0
Новая реализация классической игры Sokoban.

GreenChess 1.0
Новая шахматная программа с уникальным алгоритмом поиска…

Сапер 1.0
В вашем распоряжении маленький человечек с тремя жизнями в…

After The End 1.4.1
Космический шутер со множеством миссий.

ПиМаркет ХР 3.41
Программы для учета и анализа в торговле, специально для…

  Софт-Календарь:
В 1995 г. America Online, Compuserve, Prodigy начинают предоставлять пользователям доступ к Интернет. Луис Монье создает поисковую систему AltaVista. Регистрация доменных имен становится платной.
  Новые:
MicroFTP
Простой в использовании инструмент для работы с…

F-Album
Программа для каталогизации цифровых фотографий и других…

Anti Tracks
Программа для удаления всех следов работы за компьютером…

CryptMage
Удобный инструмент для кодирования файлов, который…

MakeAutorun
Программа для создания "авторанов" для дисков независимо от…

RegCure
Утилита для очистки и оптимизации системного реестра…

CompactDRAW
Графический редактор, в котором можно создавать веб-графику…

Смерть шпионам
Stealth-action от третьего лица, повествующий о деятельности…

GentleDraw
Программа для создания трехмерных графических моделей из…

File Deleter
Программа для безвозвратного удаления любых файлов и папок…
  Топ-10:
Синоним v1.0
Данная программа заменяет слова в тексте на синонимы. Также…

АКОЛЬ 1.8.0.5 beta 10
Профессиональная программа для копирования поврежденных…

Cool Edit Pro 2.1
Хорошая программа для работы и введения различных анализов…

WinRAR 3.30 beta
Популярный архиватор и менеджер архивов. Позволяет делать…

XingMPEG Player 3.30
Один из лучших MPEG-проигрываетелей. Воспроизводит файлы в…

ESWin 2.0
Инструментальное ПО для создания экспертных систем.

Гениальный Писатель 2.5
Генерация стихотворений/рассказов по заданной базе.

Дистрибьютор 1.6
Для людей, занимающихся дистрибьюторством товаров фирм…

Elite Solitaire 1.0
Новое рождение пасьянса Косынка.

Plato DVD Creator 2.16
Создание DVD структуры из ваших avi файлов.
   
На главную
Новости
Программы
Книги
Статьи
Новые
Топ-10
Весь софт
Мультимедиа
Утилиты
Интернет
Программирование
Игры
Десктоп
Бизнес
Драйверы
1С Предприятие
Бухгалтерия
Торговля
Складской учёт
Финансы
Документы, кадры
Органайзеры
Словари, переводчики
версия 6
версия 7.0
версия 7.5
версия 7.7
версия 8.0
Внешние компоненты
Конфигурация
Бухгалтерия
Оперативный учет
Расчет

представление даты прописью    


Обновлено 25 ноября 2005 г. 00:12:07
Рейтинг  Снижается  16 ( -2 -12.5% )
ОСWindows 95,98,ME,NT,2000,XP
Emailseregahunt@mail.ru
Авторhunter
Программы автора:
  • WinDriver Ghost - Программа для обнаружения, архивации и последующего восстановления всех драйверов, установленных в системе. Средствами программы можно создать исполняемый файл для автоматической инсталляции всех нужных драйверов.
  • Отчет "Расчетные листки" - модифицрованный отчет "Расчетные листки" из 1С:Зарплата и Кадры.Позволяет формировать расч.листки по сотрам за период, как сводные, так и помесячно.
Найти все программы автора

Описание:
//*****************************************************************************
// ПрописьДата()
//
// Параметры:
// Д - дата в формате ДД.MM.ГГГГ
// Возвращаемое значение:
// дата прописью
// Описание:
//
Функция глПрописьДата(Д) Экспорт
стрРез = "";

спсМес = СоздатьОбъект("СписокЗначений");
спсМес.ДобавитьЗначение("января");
спсМес.ДобавитьЗначение("февраля");
спсМес.ДобавитьЗначение("марта");
спсМес.ДобавитьЗначение("апреля");
спсМес.ДобавитьЗначение("мая");
спсМес.ДобавитьЗначение("июня");
спсМес.ДобавитьЗначение("июля");
спсМес.ДобавитьЗначение("августа");
спсМес.ДобавитьЗначение("сентября");
спсМес.ДобавитьЗначение("октября");
спсМес.ДобавитьЗначение("ноября");
спсМес.ДобавитьЗначение("декабря");

спсЧисл = СоздатьОбъект("СписокЗначений");
спсЧисл.ДобавитьЗначение("первое","первого");
спсЧисл.ДобавитьЗначение("второе","второго");
спсЧисл.ДобавитьЗначение("третье","третьего");
спсЧисл.ДобавитьЗначение("четвертое","четвертого");
спсЧисл.ДобавитьЗначение("пятое","пятого");
спсЧисл.ДобавитьЗначение("шестое","шестого");
спсЧисл.ДобавитьЗначение("седьмое","седьмого");
спсЧисл.ДобавитьЗначение("восьмое","восьмого");
спсЧисл.ДобавитьЗначение("девятое","девятого");

//числительные им.падеж
спсЧислИм = СоздатьОбъект("СписокЗначений");
спсЧислИм.ДобавитьЗначение("тысяча","тысячного");
спсЧислИм.ДобавитьЗначение("две тысячи","двухтысячного");
спсЧислИм.ДобавитьЗначение("три тысячи","трехтысячного");
спсЧислИм.ДобавитьЗначение("четыре тысячи","четырехтысячного");
спсЧислИм.ДобавитьЗначение("пять","пятитысячного");
спсЧислИм.ДобавитьЗначение("шесть","шеститысячного");
спсЧислИм.ДобавитьЗначение("семь","семитысячного");
спсЧислИм.ДобавитьЗначение("восемь","восьмитысячного");
спсЧислИм.ДобавитьЗначение("девять","девятитысячного");

спсСотни = СоздатьОбъект("СписокЗначений");
спсСотни.ДобавитьЗначение("сто");
спсСотни.ДобавитьЗначение("двести");
спсСотни.ДобавитьЗначение("триста");
спсСотни.ДобавитьЗначение("четыреста");
спсСотни.ДобавитьЗначение("пятьсот");
спсСотни.ДобавитьЗначение("шестьсот");
спсСотни.ДобавитьЗначение("семьсот");
спсСотни.ДобавитьЗначение("восемьсот");
спсСотни.ДобавитьЗначение("девятьсот");

//десятки им.падеж
спсДесИм = СоздатьОбъект("СписокЗначений");
спсДесИм.ДобавитьЗначение("","десятого");
спсДесИм.ДобавитьЗначение("двадцать","двадцатого");
спсДесИм.ДобавитьЗначение("тридцать","тридцатого");
спсДесИм.ДобавитьЗначение("сорок","сорокового");
спсДесИм.ДобавитьЗначение("пятьдесят","пятидесятого");
спсДесИм.ДобавитьЗначение("шестьдесят","шестидесятого");
спсДесИм.ДобавитьЗначение("семьдесят","семидесятого");
спсДесИм.ДобавитьЗначение("восемьдесят","восьмидесятого");
спсДесИм.ДобавитьЗначение("девяносто","девяностого");

//субдесятки род.падеж
спсСубДесРод = СоздатьОбъект("СписокЗначений");
спсСубДесРод.ДобавитьЗначение("одиннадцатого");
спсСубДесРод.ДобавитьЗначение("двенадцатого");
спсСубДесРод.ДобавитьЗначение("тринадцатого");
спсСубДесРод.ДобавитьЗначение("четырнадцатого");
спсСубДесРод.ДобавитьЗначение("пятнадцатого");
спсСубДесРод.ДобавитьЗначение("шестнадцатого");
спсСубДесРод.ДобавитьЗначение("семнадцатого");
спсСубДесРод.ДобавитьЗначение("восемнадцатого");
спсСубДесРод.ДобавитьЗначение("девятнадцатого");

спсДес = СоздатьОбъект("СписокЗначений");
спсДес.ДобавитьЗначение("десятое");
спсДес.ДобавитьЗначение("двадцатое","двадцать");
спсДес.ДобавитьЗначение("тридцатое","тридцать");
спсДес.ДобавитьЗначение("сороковое","тридцать");
спсДес.ДобавитьЗначение("пятидесятое","тридцать");
спсДес.ДобавитьЗначение("шестидесятое","тридцать");
спсДес.ДобавитьЗначение("семидесятое","тридцать");

спсСубДес = СоздатьОбъект("СписокЗначений");
спсСубДес.ДобавитьЗначение("одиннадцатое");
спсСубДес.ДобавитьЗначение("двенадцатое");
спсСубДес.ДобавитьЗначение("тринадцатое");
спсСубДес.ДобавитьЗначение("четырнадцатое");
спсСубДес.ДобавитьЗначение("пятнадцатое");
спсСубДес.ДобавитьЗначение("шестнадцатое");
спсСубДес.ДобавитьЗначение("семнадцатое");
спсСубДес.ДобавитьЗначение("восемнадцатое");
спсСубДес.ДобавитьЗначение("девятнадцатое");

спсДаты = СтрЗаменить(СокрЛП(Д),".",РазделительСтрок);
//разбираем день
стрДень = СокрЛП(Число(СтрПолучитьСтроку(спсДаты,1)));
Если СтрДлина(стрДень)=1 Тогда
стрДень = спсЧисл.ПолучитьЗначение(Число(стрДень));
Иначе
десДень = Число(Лев(стрДень,1));
едДень = Число(Прав(стрДень,1));

Если едДень=0 Тогда
стрДень = спсДес.ПолучитьЗначение(десДень);
Иначе
Если десДень>1 Тогда
т = ""; спсДес.ПолучитьЗначение(десДень,т);
стрДень = т+" "+спсЧисл.ПолучитьЗначение(едДень);
Иначе
стрДень = спсСубДес.ПолучитьЗначение(едДень);
КонецЕсли;
КонецЕсли;
КонецЕсли;
//разбираем месяц
стрМес = спсМес.ПолучитьЗначение(Число(СтрПолучитьСтроку(спсДаты,2)));

//разбираем год
стрГод = СтрПолучитьСтроку(спсДаты,3);
длинаГода = СтрДлина(стрГод);
Если длинаГода=4 Тогда
тыс = Сред(стрГод,1,1); сот = Сред(стрГод,2,1); дес = Сред(стрГод,3,1); ед = Сред(стрГод,4,1);
_т = спсЧислИм.ПолучитьЗначение(Число(тыс));
Если (Число(сот)=0) и (Число(дес)=0) и (Число(ед)=0) Тогда
миллениум = ""; спсЧислИм.ПолучитьЗначение(Число(тыс),миллениум);
стрГод = миллениум;
Иначе
с = ""; дс = ""; е = "";
Если Число(сот)0 Тогда
с = спсСотни.ПолучитьЗначение(Число(сот));
КонецЕсли;
Если Число(дес)0 Тогда
Если Число(ед)=0 Тогда
_дг = ""; спсДесИм.ПолучитьЗначение(Число(дес),_дг);
дс = _дг;
Иначе
Если Число(дес)>1 Тогда
дс = спсДесИм.ПолучитьЗначение(Число(дес));
Иначе
дс = спсСубДесРод.ПолучитьЗначение(Число(ед));
КонецЕсли;

КонецЕсли;
КонецЕсли;
Если (Число(дес)>1) или (Число(дес)=0) Тогда
Если Число(ед)0 Тогда
//е = "";
спсЧисл.ПолучитьЗначение(Число(ед),е);
КонецЕсли;
КонецЕсли;
стрГод = _т+?(ПустоеЗначение(с)=0," ","")+с+?(ПУстоеЗначение(дс)=0," ","")+дс+" "+е;
КонецЕсли;
Иначе

КонецЕсли;
стрГод = стрГод+" года";
стрРез = стрДень+" "+стрМес+" "+стрГод;
//Сообщить(стрДень+" "+стрМес+" "+стрГод);
Возврат стрРез;
КонецФункции //ПрописьДата*/
Загрузить  Загрузить представление даты прописью на 1c.proclub.ru
Найти последнюю версиюНайти последнюю версию представление даты прописью

Похожие программы:
    Найти все программы похожие на представление даты прописью

    Похожие новости:
    • Предсказана дата смерти iPhone - Ресурс PC Mag создал специальную страничку, на которой владельцы iPhone смогут узнать, когда «умрет» их телефон. Вы просто вводите дату покупки iPhone и получаете точную…
    • Archos 604 – практически официальное представление - Вслед за свои братом Archos 404 представлен новый современный портативный мультимедиа плеер Archos 604. Сегодня мы имеем честь представить вам полные спецификации этого…
    Найти все новости похожие на представление даты прописью

    Похожие статьи:
    Найти все статьи похожие на представление даты прописью


    На главную > Программы > Бизнес > 1С Предприятие > версия 7.7 > Расчет > представление даты прописью

    скачай также:
    Расписание 2.5
    Multi Project Planner 2.0
    AutoМебель 0.9.9.9
    download also english software:
    CRMadar 3.627
    EmPowered Programmer 1.5
    Elegant InterFace 4.0 4.0 04-06-03
    скачай также:
    Dolphins 3D Screensaver 1.0
    PPT Repair Free 1.0
    Mass Downloader 3.2 SR2

    Copyright © 2001—2016 SoftSearch
    Идея:
    Дизайн: Дамир Салахов
    Реклама на сайте
    Контакты: