Поиск по каталогам и архивам программ   
 Пример: • English
• Новые
• ТОП
        Читаем
Софт-блог!
Поиск:   
     

На главную > Программы > Бизнес > 1С Предприятие > версия 7.7 > Расчет > представление даты прописью

  Их ищут:
SfGeodesy 1.0
Программа SfGeodesy позволяет решать следующие задачи…

Child Lock 2.0.0.6
"Child Lock" позволяет родителям(администраторам…

PhoA 1.1.2
Эта программа программа позволяет организовать все имеющиеся…

Virtual Chemistry Lab
Программа представляет из себя виртуальную химическую…

LanShutDown 3.0.1
Выключение или перезагрузка компьютеров по сети.

Выключатель v2.0
Собираетесь куда-то идти, но ведь работает программа, что же…

AvocadoSelling 1.6
Программа автоматизации складского учета и торговли.

LuckCity
Пошаговая экономическая стратегия.

Биржа 2 2.0
Смесь логической, стратегической, азартной и карточной…

Платежка 2.0.4
Печать платежных поручений из Excel с ведением базы…

  Софт-Календарь:
15 декабря 1951 г. утвержден отчет руководителя лаборатории электросистем члена-корр. АН СССР И. С. Брука "Автоматическая вычислительная машина М-1", позже вошедший в историю вычислительной техники СССР.
  Новые:
APS
Утилита предназначена для обнаружения хакерских атак. APS…

Fast Cleaner
Программа для очистки жесткого диска от временных файлов…

Password Corral
Утилита для безопасного хранения паролей. Она использует…

Ex Machina Gold
В этой игре вам предстоит колесить по миру в качестве…

IconCool Editor
Мощный редактор иконок и курсоров. Программа обладает…

Alive Video Converter
Многоформатный конвертер видео файлов, поддерживающий все…

Juiced
Уличные гонки, благодаря которым вы сможете окунуться в…

Digital Physiognomy
Программа определяет по фотографии психологические…

Just NavBars
Программа для создания графического меню навигации для…

Perfect Sound Recorder
Профессиональная программа для записи звука с любого…
  Топ-10:
Disktest PRO 1.3
Набор утилит для тестирования качества поверхности дискеты…

Kandidat CMS 1.3.6
Простейшая система построения сайтов - Kandidat CMS…

Журнал трейдера 1.1
Программа предназначена для учета биржевых сделок, сделок по…

Adobe PageMaker 7.0.1
Русификатор к программе Adobe PageMaker 7.0.1

Punto Switcher 2.9
Punto Switcher автоматический! переключатель раскладки…

Расчет выслуги лет 2.2
Программа предназначена для помощи работнику отдела кадров…

VoltageFall 1.3
Программа позволяет рассчитывать потери напряжения в…

Web-Регистратор 6.0
Web-Регистратор 6.0. Увеличьте посещаемость вашего сайта…

Secundomer 3.5
Программа предназначена для отсчета секунд, минут, часов.

SoftRegistring 1.0
Защита вашей программы от пиратского копирования.
   
На главную
Новости
Программы
Книги
Статьи
Новые
Топ-10
Весь софт
Мультимедиа
Утилиты
Интернет
Программирование
Игры
Десктоп
Бизнес
Драйверы
1С Предприятие
Бухгалтерия
Торговля
Складской учёт
Финансы
Документы, кадры
Органайзеры
Словари, переводчики
версия 6
версия 7.0
версия 7.5
версия 7.7
версия 8.0
Внешние компоненты
Конфигурация
Бухгалтерия
Оперативный учет
Расчет

представление даты прописью    


Обновлено 25 ноября 2005 г. 00:12:07
Рейтинг  Снижается  16 ( -2 -12.5% )
ОСWindows 95,98,ME,NT,2000,XP
Emailseregahunt@mail.ru
Авторhunter
Программы автора:
  • WinDriver Ghost - Программа для обнаружения, архивации и последующего восстановления всех драйверов, установленных в системе. Средствами программы можно создать исполняемый файл для автоматической инсталляции всех нужных драйверов.
  • Отчет "Расчетные листки" - модифицрованный отчет "Расчетные листки" из 1С:Зарплата и Кадры.Позволяет формировать расч.листки по сотрам за период, как сводные, так и помесячно.
Найти все программы автора

Описание:
//*****************************************************************************
// ПрописьДата()
//
// Параметры:
// Д - дата в формате ДД.MM.ГГГГ
// Возвращаемое значение:
// дата прописью
// Описание:
//
Функция глПрописьДата(Д) Экспорт
стрРез = "";

спсМес = СоздатьОбъект("СписокЗначений");
спсМес.ДобавитьЗначение("января");
спсМес.ДобавитьЗначение("февраля");
спсМес.ДобавитьЗначение("марта");
спсМес.ДобавитьЗначение("апреля");
спсМес.ДобавитьЗначение("мая");
спсМес.ДобавитьЗначение("июня");
спсМес.ДобавитьЗначение("июля");
спсМес.ДобавитьЗначение("августа");
спсМес.ДобавитьЗначение("сентября");
спсМес.ДобавитьЗначение("октября");
спсМес.ДобавитьЗначение("ноября");
спсМес.ДобавитьЗначение("декабря");

спсЧисл = СоздатьОбъект("СписокЗначений");
спсЧисл.ДобавитьЗначение("первое","первого");
спсЧисл.ДобавитьЗначение("второе","второго");
спсЧисл.ДобавитьЗначение("третье","третьего");
спсЧисл.ДобавитьЗначение("четвертое","четвертого");
спсЧисл.ДобавитьЗначение("пятое","пятого");
спсЧисл.ДобавитьЗначение("шестое","шестого");
спсЧисл.ДобавитьЗначение("седьмое","седьмого");
спсЧисл.ДобавитьЗначение("восьмое","восьмого");
спсЧисл.ДобавитьЗначение("девятое","девятого");

//числительные им.падеж
спсЧислИм = СоздатьОбъект("СписокЗначений");
спсЧислИм.ДобавитьЗначение("тысяча","тысячного");
спсЧислИм.ДобавитьЗначение("две тысячи","двухтысячного");
спсЧислИм.ДобавитьЗначение("три тысячи","трехтысячного");
спсЧислИм.ДобавитьЗначение("четыре тысячи","четырехтысячного");
спсЧислИм.ДобавитьЗначение("пять","пятитысячного");
спсЧислИм.ДобавитьЗначение("шесть","шеститысячного");
спсЧислИм.ДобавитьЗначение("семь","семитысячного");
спсЧислИм.ДобавитьЗначение("восемь","восьмитысячного");
спсЧислИм.ДобавитьЗначение("девять","девятитысячного");

спсСотни = СоздатьОбъект("СписокЗначений");
спсСотни.ДобавитьЗначение("сто");
спсСотни.ДобавитьЗначение("двести");
спсСотни.ДобавитьЗначение("триста");
спсСотни.ДобавитьЗначение("четыреста");
спсСотни.ДобавитьЗначение("пятьсот");
спсСотни.ДобавитьЗначение("шестьсот");
спсСотни.ДобавитьЗначение("семьсот");
спсСотни.ДобавитьЗначение("восемьсот");
спсСотни.ДобавитьЗначение("девятьсот");

//десятки им.падеж
спсДесИм = СоздатьОбъект("СписокЗначений");
спсДесИм.ДобавитьЗначение("","десятого");
спсДесИм.ДобавитьЗначение("двадцать","двадцатого");
спсДесИм.ДобавитьЗначение("тридцать","тридцатого");
спсДесИм.ДобавитьЗначение("сорок","сорокового");
спсДесИм.ДобавитьЗначение("пятьдесят","пятидесятого");
спсДесИм.ДобавитьЗначение("шестьдесят","шестидесятого");
спсДесИм.ДобавитьЗначение("семьдесят","семидесятого");
спсДесИм.ДобавитьЗначение("восемьдесят","восьмидесятого");
спсДесИм.ДобавитьЗначение("девяносто","девяностого");

//субдесятки род.падеж
спсСубДесРод = СоздатьОбъект("СписокЗначений");
спсСубДесРод.ДобавитьЗначение("одиннадцатого");
спсСубДесРод.ДобавитьЗначение("двенадцатого");
спсСубДесРод.ДобавитьЗначение("тринадцатого");
спсСубДесРод.ДобавитьЗначение("четырнадцатого");
спсСубДесРод.ДобавитьЗначение("пятнадцатого");
спсСубДесРод.ДобавитьЗначение("шестнадцатого");
спсСубДесРод.ДобавитьЗначение("семнадцатого");
спсСубДесРод.ДобавитьЗначение("восемнадцатого");
спсСубДесРод.ДобавитьЗначение("девятнадцатого");

спсДес = СоздатьОбъект("СписокЗначений");
спсДес.ДобавитьЗначение("десятое");
спсДес.ДобавитьЗначение("двадцатое","двадцать");
спсДес.ДобавитьЗначение("тридцатое","тридцать");
спсДес.ДобавитьЗначение("сороковое","тридцать");
спсДес.ДобавитьЗначение("пятидесятое","тридцать");
спсДес.ДобавитьЗначение("шестидесятое","тридцать");
спсДес.ДобавитьЗначение("семидесятое","тридцать");

спсСубДес = СоздатьОбъект("СписокЗначений");
спсСубДес.ДобавитьЗначение("одиннадцатое");
спсСубДес.ДобавитьЗначение("двенадцатое");
спсСубДес.ДобавитьЗначение("тринадцатое");
спсСубДес.ДобавитьЗначение("четырнадцатое");
спсСубДес.ДобавитьЗначение("пятнадцатое");
спсСубДес.ДобавитьЗначение("шестнадцатое");
спсСубДес.ДобавитьЗначение("семнадцатое");
спсСубДес.ДобавитьЗначение("восемнадцатое");
спсСубДес.ДобавитьЗначение("девятнадцатое");

спсДаты = СтрЗаменить(СокрЛП(Д),".",РазделительСтрок);
//разбираем день
стрДень = СокрЛП(Число(СтрПолучитьСтроку(спсДаты,1)));
Если СтрДлина(стрДень)=1 Тогда
стрДень = спсЧисл.ПолучитьЗначение(Число(стрДень));
Иначе
десДень = Число(Лев(стрДень,1));
едДень = Число(Прав(стрДень,1));

Если едДень=0 Тогда
стрДень = спсДес.ПолучитьЗначение(десДень);
Иначе
Если десДень>1 Тогда
т = ""; спсДес.ПолучитьЗначение(десДень,т);
стрДень = т+" "+спсЧисл.ПолучитьЗначение(едДень);
Иначе
стрДень = спсСубДес.ПолучитьЗначение(едДень);
КонецЕсли;
КонецЕсли;
КонецЕсли;
//разбираем месяц
стрМес = спсМес.ПолучитьЗначение(Число(СтрПолучитьСтроку(спсДаты,2)));

//разбираем год
стрГод = СтрПолучитьСтроку(спсДаты,3);
длинаГода = СтрДлина(стрГод);
Если длинаГода=4 Тогда
тыс = Сред(стрГод,1,1); сот = Сред(стрГод,2,1); дес = Сред(стрГод,3,1); ед = Сред(стрГод,4,1);
_т = спсЧислИм.ПолучитьЗначение(Число(тыс));
Если (Число(сот)=0) и (Число(дес)=0) и (Число(ед)=0) Тогда
миллениум = ""; спсЧислИм.ПолучитьЗначение(Число(тыс),миллениум);
стрГод = миллениум;
Иначе
с = ""; дс = ""; е = "";
Если Число(сот)0 Тогда
с = спсСотни.ПолучитьЗначение(Число(сот));
КонецЕсли;
Если Число(дес)0 Тогда
Если Число(ед)=0 Тогда
_дг = ""; спсДесИм.ПолучитьЗначение(Число(дес),_дг);
дс = _дг;
Иначе
Если Число(дес)>1 Тогда
дс = спсДесИм.ПолучитьЗначение(Число(дес));
Иначе
дс = спсСубДесРод.ПолучитьЗначение(Число(ед));
КонецЕсли;

КонецЕсли;
КонецЕсли;
Если (Число(дес)>1) или (Число(дес)=0) Тогда
Если Число(ед)0 Тогда
//е = "";
спсЧисл.ПолучитьЗначение(Число(ед),е);
КонецЕсли;
КонецЕсли;
стрГод = _т+?(ПустоеЗначение(с)=0," ","")+с+?(ПУстоеЗначение(дс)=0," ","")+дс+" "+е;
КонецЕсли;
Иначе

КонецЕсли;
стрГод = стрГод+" года";
стрРез = стрДень+" "+стрМес+" "+стрГод;
//Сообщить(стрДень+" "+стрМес+" "+стрГод);
Возврат стрРез;
КонецФункции //ПрописьДата*/
Загрузить  Загрузить представление даты прописью на 1c.proclub.ru
Найти последнюю версиюНайти последнюю версию представление даты прописью

Похожие программы:
    Найти все программы похожие на представление даты прописью

    Похожие новости:
    • Предсказана дата смерти iPhone - Ресурс PC Mag создал специальную страничку, на которой владельцы iPhone смогут узнать, когда «умрет» их телефон. Вы просто вводите дату покупки iPhone и получаете точную…
    • Archos 604 – практически официальное представление - Вслед за свои братом Archos 404 представлен новый современный портативный мультимедиа плеер Archos 604. Сегодня мы имеем честь представить вам полные спецификации этого…
    Найти все новости похожие на представление даты прописью

    Похожие статьи:
    Найти все статьи похожие на представление даты прописью


    На главную > Программы > Бизнес > 1С Предприятие > версия 7.7 > Расчет > представление даты прописью

    скачай также:
    Mar Password Generator 1.21
    LogInLog 1.0
    XUM32 1.03
    download also english software:
    Right WebGallery 2.6
    Network Configuration Management 4.77
    Naevius Wallpaper Changer 1.0
    скачай также:
    BtoCAD Ptofessional 2009
    Площадь 1.0
    Advanced Grapher 2.2

    Copyright © 2001—2016 SoftSearch
    Идея:
    Дизайн: Дамир Салахов
    Реклама на сайте
    Контакты: